Start Instructions for DSE 200

Computer requirements

Startup directions for GitHub

Directions for a local installation

We will support Mac OS X and Ubuntu Linux for DSE 200. We have provided startup instructions for Windows users, however many of the DSE 200 course demonstrations and assignments rely on Unix commands that are not available on Windows. Windows users will also experience path and environment related issues. We recommend that Windows users use Ubuntu Linux in a virtual machine for DSE 200. See the DSE 200 Computer Requirements.

Running both Python 2.7/3.6 on same machine:

All courses, in general, will use Python 2.7. If you wish to use both Python 2.7 and 3.6 on your system for some reason, it is possible using Anaconda 4.1.0 or later. You may update your Anaconda using the command:

conda update conda
conda update anaconda

Then, use the following commands to create two Python environments.

conda create -n py27 python=2.7 ipykernel
conda create -n py36 python=3.6 ipykernel

Now, you may go to your Jupyter Notebook and select the Python version you wish to use. For installing specific packages on selected Python version, activate the corresponding Python and then install packages.

Note that if you are using Anaconda 3 or earlier, you may want to refer this link.